“It is my great pleasure and privilege to announce the availability of FreeBSD 6.1-RELEASE. This release is the next step in the development of the 6.X branch, delivering several performance improvements, many bugfixes, and a few new features. These include: Addition of a keyboard multiplexer. This allows USB and PS/2 keyboards to coexist without any special options at boot. Many fixes for filesystem stability. High load stress tests are now run successfully on a regular basis as part of the normal FreeBSD QA process. Automatic configuration for man Bluetooth devices, as well as automatic support for running WiFi access points. Addition of drivers for new ethernet and SAS and SATA RAID controllers.”
I’m primarily a GNU/Linux user. Just would like to know the *easiest* way to update to Gnome 2.14 on FreeBSD 6.1. I did try portupgrade method few months ago and it broke the entire installation.
Read /usr/ports/UPDATING
This file has vital information about changes in ports system. GNOME updates are usually listed there and include a link to FreeBSD’s GNOME site where you can download a script that does upgrading without problems.
Use that script instead of portupgrade.
GNOME is so large and complicated set of interdependencies that portupgrade may not figure it out properly, that’s why there’s that script.
You could also install quite fresh GNOME from packages by using sysinstall.
This file has vital information about changes in ports system. GNOME updates are usually listed there and include a link to FreeBSD’s GNOME site where you can download a script that does upgrading without problems.
Use that script instead of portupgrade.
No, you don’t need the script now. Use portupgrade instead as stated in the /usr/ports/UPDATING.
GNOME is so large and complicated set of interdependencies that portupgrade may not figure it out properly, that’s why there’s that script.
Not anymore when we have found a bug in libtool. We no longer need the script, which portupgrade will working fine now.
The easiest way is installing the binary packages for 2.14. Heres how:
set PACKAGESITE to:
http://www.marcuscom.com/tb/packages/6.0-FreeBSD/Latest/
then pkg_add -r gnome2
But to use this method you have to remove your current gnome installation and possibly some of x.org first.
Edited 2006-05-09 10:28
This is an issue with FreeBSD. I love FreeBSD but the applications and package management has been pretty messy for quite sometime. If you want to get gnome going, I would suggest a fresh install – backup all your files and do a fresh install from Marcus com via binnay packages. The source install via ports may or may not work, but its not going to give you such an improved performance that you spend 12hours compiling code in the hope that it works. I say this because I have gone through this every single time with every FreeBSD release. I am going to go through this again today.
It would be great if there was some form of a binary package mangement system for FreeBSD. The prots system is outdated and over-rated.
Despite this I still use FreeBSD but only packages. I have also started to experiment with Ubuntu lately for its Gnome support.
I wonder if anyone is working on porting over OpenBSD’s new pkg_tools — they offer excellent package management without rocking the boat.
FreeBSD has binary package management – you can install, remove, upgrade binary packages with pkg_* tools. You can even create binary packages from software installed from ports, and then use those packages on other machines!
Ports system is outdated? What are you blathering about? It just works, and everyone loves it – it offers greater flexibility than binary-only systems, and what makes it really great is it’s seamless integration with the binary package management system. With make package-recursive you can have binary packages automatically created in /usr/ports/packages, which you can export via NFS and you can install every package with pkg_add on other machines! FreeBSD offers the best of both worlds of source only and binary only systems.
A easy way of upgrading to gnome2.14 would be:
#portsnap fetch
#portsnap extract
#portsnap update
#portupgrade -rR x11/gnome2
If you have KDE installed as well you could get an error message like: avahi is blocking howl…error1
Just entering portupgrade -o net/avahi -f howl will fix.
From the muc.lists.freebsd.ports mailinglist:
is the equivalent of saying ‘replace the installed package
xscreensaver-gnome with x11/gnome-screensaver’. In this case
these are two different ports, but they provide the same
functionality. In other cases, they will CONFLICT,
installing files with identical names in the same place.
the same is true for the lua package:
from the same mailinglist:[1]===> lua-5.0.2_1 conflicts with installed package(s):
lua-5.1
UPDATING/20060506 says to fix this with :
portupgrade -f -o lang/lua50 lua-5.1 [/i]
Hope this will help you enjoy gnome 2.14 on FreeBSD ๐
#portsnap fetch
#portsnap extract
#portsnap update
#portupgrade -rR x11/gnome2
Doing an update after an extract makes no sense. You perform an extract only the first time you use portsnap to extract the ports tree as a whole. After that it’s just update.
Oh well upgrade time. Hey, and they have the new logo on their website too. Great. Looks kinda odd having beastie together with the new logo. They should glass-up beastie too… or not!
The new logo and title font suck, imo.
Just upgraded then, and compiled using the following switches in my make.conf file:
CFLAGS=-Os -march=pentiumpro
So far, everything is really stable, and what is even better, my iPod is now properly detected and shows up in the /dev directory! ๐ I couldn’t originally work out the problem, but it seems that since them fixing up the USB keyboard issue, they also inadvertantly fixed up the iPod issue at the same time.
I also have enabled SMP/HTT support as well via custom config (called TCHAIKOVSKY).
Right now, I’m doing a clean install, deleted all the custom ports, and rebuilding again – everything going very smoothly, hopefully in a few hours I’ll have a nice ‘n stable machine soon.
In regards to ULE scheduler, is there an ETA as to when it will be stable enough for every day use? I’m assuming the reason that the FreeBSD engineers have stuck with the 4.4BSD scheduler is because there are some issues still to be sorted with the ULE one.
Browser: Lynx/2.8.5rel.4 libwww-FM/2.14
In regards to ULE scheduler, is there an ETA as to when it will be stable enough for every day use? I’m assuming the reason that the FreeBSD engineers have stuck with the 4.4BSD scheduler is because there are some issues still to be sorted with the ULE one.
Last word (from a long time FreeBSD kernel hacker) is
that it is not in great shape, and it sounds like the
ETA is indefinite.
http://marc.theaimsgroup.com/?l=freebsd-performance&m=1147034374275…
Is there a way to change the terminal font size in freeBSD ala the vga=xxx kernel boot parameter in Linux ?
There is, but I think you have to use the vidcontrol(1) command. To make these changes take effect everytime you boot you may have to make an entry in the rc.conf file to set the font. Try looking at the handbook/man pages. The freebsd mailing lists are probably a better place to post this question.
Hopes this helps.
Edited 2006-05-09 13:08
Go into sysinstall, Configure, Console, Font.
Swiss has always been my choice.
I started using FreeBSD at 4.10. I love it. 6.0 is real nice. I prefer KDE to Gnome for a desktop. Wireless works great. For some funny reason, FreeBSD never liked my U.S. Robotics USR5610B 56Kbps PCI Bus (Plug and Play) Internal PCI Performance Pro Fax Modem. I have yet been able to figure out why. Neither Debian nor Windows XP have any trouble with it, just FreeBSD. Just one of those things.
Anybody working on this? I’m not a FreeBSD user, but I’d love to try it under Xen on my Linux machines.
It looks like some people are working on getting Xen merged into the FreeBSD 7 tree:
http://www.fsmware.com/
Reply still doesn’t work in konqueror (this is the only site I have problems with) – so I deleted the original message, and posted it as a reply in Firefox.
When will someone fix osnews?
Edited 2006-05-09 15:07
It’s good to see another BSD release. Unfortunately, I recently have switched to using Gentoo for a few reasons that I won’t get into here.
I’m hoping to be able to set up another BSD server in the future cause personally, I love it. Portupgrade might be showing a bit of age, but it’s still powerful and the reason I ended up picking up FreeBSD back in about the 4.6 days.
Hmmm. Maybe I should do a conversion this weekend….
What FreeBSD really needs is an official binary package update system similar to Yum or Apt. While there is no problem with how things are currently done when you have thousands of machines to administer, it really does become a hassle if you just have a few. For example, at home, I really would have liked to install FreeBSD, but I chose to install CentOS because I really do not have the time to patch that system up manually. With CentOS, I just have Yum scheduled to update the system. The same is true at my work place too. I have chosen to install about 8 CentOS systems. My preferred choice was FreeBSD but I really don’t have time to manually keep the systems up to date at work either.
i’m sure there are ways to have one build machine and be able to push out updates to the rest of your machines.
I rather use emerge and apt if necessary.Yum is superceeded by smart long time ago ๐
Would be lovely to see the devs porting “emerge” to FreeBSD.Although portupgrade still serves me quite well.
Like “portupgrade -rR x11/gnome2”,upgrades my currently installed gnome DE.
Eyecandy lays in the hands of the beholder.
Would be lovely to see the devs porting “emerge” to FreeBSD.Although portupgrade still serves me quite well.
Check out the Gentoo/BSD project. There was an interview with one of the Gentoo/FreeBSD developers recently on one of the BSD news sites (daemonnews, maybe).
tnx!
I recall reading in the handbook where it suggests how you do packaging for “thousands” of machines. IIRC you make the packages for just one of the machines, then set the main host as the package site and update from there.
If you check portupdate, you will see it has a -P option for using packages if available, to do the updates.
Sometimes people need to do some more homework on what the best way to manage many hosts…you might have yum update each system independantly which is probably quite inneffcient if each host is having to download the packages.
GNOME updates are usually listed there and include a link to FreeBSD’s GNOME site where you can download a script that does upgrading without problems.
Use that script instead of portupgrade.
It’s funny you didn’t read it yourself.
20060429:
AFFECTS: All GNOME users
AUTHOR: [email protected]
GNOME has been updated to 2.14. This new release does NOT require the
use of the gnome_upgrade.sh script. That script should not be used.
Instead, use the following simple recipe:
pkgdb -Ff
portupgrade -o net/avahi -f howl
portupgrade -o x11/gnome-screensaver -f xscreensaver-gnome
portupgrade -a
The source install via ports may or may not work, but its not going to give you such an improved performance that you spend 12hours compiling code in the hope that it works. I say this because I have gone through this every single time with every FreeBSD release. I am going to go through this again today.
I don’t know where you talk about. I upgraded FreeBSD and GNOME many times on this desktop.
From FreeBSD 5.3-RELEASE to 6.1-RELEASE. I even upgraded to every BETA and RC on this box. I used GNOME on this box from 2.8 to 2.14. Before I used the script and the last time /usr/ports/UPDATING and portupgrade.
Be creative! In the past I had to do portupgrade several times to get GNOME complete, so what. It works like a charm after all. By the way this time the upgrade to 2.14 was very easy and went smooth.
Edited 2006-05-09 17:26
My preferred choice was FreeBSD but I really don’t have time to manually keep the systems up to date at work either.
Are you telling you go sit and waiting for each install/compile? I personally don’t get the point; what is the point if software is updated a few hours later? You don’t have to wait, open a few terminals and run “portsnap fetch ; portsnap update ; portupgrade -a” and it does its job. Besides that, are there over 14000 packages available with Yum or APT-Get?
“You don’t have to wait, open a few terminals and run “portsnap fetch ; portsnap update ; portupgrade -a” and it does its job. Besides that, are there over 14000 packages available with Yum or APT-Get?”
That is the issue. We end up waiting for a long time.
And those 14000 packages are not always maintained. Are you saying all 14000 packages are well tested and will install without any issues on a FreeBSD system? The number of packages is not appropriate measurement here.
Take Ubuntu for example. Couple of years ago no one ever heard of it. Now its one of the most popular distros out there. Lets face it. They are not touting their umpteen thousands of packages. They made it easy and simple to use, manage, and install applications.
FreeBSD is good for many tasks but being a desktop is not one – not right now. I have been a BSD user for many years and I would love to see this change but until then I will not be directing beginers to it.
They are not touting their umpteen thousands of packages
From the Ubuntu.com website: “Ubuntu includes more than 16,000 pieces of software”. They appear to do exactly that.
I have to disagree that BSD is not ready for the desktop: the FreeBSD ports system includes everything you need, such as KDE and Gnome. I even know a BSD ‘distro’ that’s aimed primarily at the desktop: PC-BSD http://www.pcbsd.org/.
noescom talked about PC-BSD, but there is also DesktopBSD: http://www.desktopbsd.org/
What is nice with this “version” of FreeBSD is that it is so compatible with the “normal” FreeBSD that they have put their tools into the FreeBSD port system, in sysutils/desktopbsd-tools
Combined with KDE, it may ease the use of FreeBSD for new users. For instance, there are tools to easily mount/unmount devices, to create users, and I love the GUI to manage ports.
It is less powerfull than with a textual terminal, but it may be a start.
Take Ubuntu for example. Couple of years ago no one ever heard of it. Now its one of the most popular distros out there. Lets face it. They are not touting their umpteen thousands of packages. They made it easy and simple to use, manage, and install applications.
Ubuntu, of course, is based on Debian, one of the biggest and oldest GNU/Linux distros. That explains the large number of packages and the sophisticated package management system that Ubuntu has — it all comes from Debian.
FreshPorts http://www.freshports.org/ has some statistics about FreeBSD’s Ports.
Well… Really, Debian has a great amount of packages (more than FreeBSD ports) only because the majority of them, are splitted in smallest packages. An examples; postgresql, bind, mysql, etc, etc.
I will apologize about the inconvenient of my bad english… sorry for that.
The point that I was trying to make was not about the number of available packages. The passage I quoted seems to suggest that Ubuntu has developed a sophisticated package management system and a large amount of packages within just a few years. An equivalent statement would be that DesktopBSD has developed a robust operating system with an advanced package management within just a few years.
I pointed out that it takes a lot of time and work to develop such features. DesktopBSD is excellent because it’s built on FreeBSD. Similarly, Ubuntu has become popular because it’s based on the work done in Debian.
But if you wish to discuss the number of available packages in Debian and FreeBSD, please consider that splitting applications into many binary packages is a way of introducing modularity and flexibility into a binary package management system. It gives you more choices about which features you want to install and which you don’t. Debian (and Ubuntu) have a complicated dependency handling system that has optional “recommends” and “suggests” in addition to “depends”. Debian’s apt-get can be used to build individual packages from source (fetching their build dependencies) and there’s apt-build that more or less equals FreeBSD’s Ports. With apt-build you can rebuild your whole Debian system from source, using your own optimizations. Debian is also known for the rigorous quality assurance of packages, especially for the packages that are accepted to stable releases.
“apt-cache stats” for binary packages in Debian stable:
Total package names : 20005
Normal packages: 15681
“apt-cache stats” for binary packages in Debian testing:
Total package names : 22304
Normal packages: 17197
“apt-cache stats” for binary packages in Debian unstable:
Total package names : 23783
Normal packages: 18368
There are also loads of unofficial packages available for Debian and most of these are listed at http://www.apt-get.org/ Of course, you don’t get any security-related or bug-fixing support for these unofficial packages.
FreeBSD is good for many tasks but being a desktop is not one – not right now. I have been a BSD user for many years and I would love to see this change but until then I will not be directing beginers to it.
I simply do not agree with that. I am not in a hurry. I do my things while on virtual desktop number 4 a terminal with portupgrade runs. I don’t care to have the new Firefox a few hours later while the current installed one does its job very good. ๐
Let’s make things clear. The fact is not FreeBSD “is good for many tasks but being a desktop is not one – not right now”. The fact is *you* don’t think it’s ready. ๐
And I don’t think Windows is ready. I troll you not.
Am I right in thinking you can pkg_add packagex, then make install clean it from source, and use the package whilst your port is compiling? This works on Gentoo.
This should be a nice release. Have not used FreeBSD since 4.8, so am looking forward to trying this out again.
Am I right in thinking you can pkg_add packagex, then make install clean it from source, and use the package whilst your port is compiling? This works on Gentoo.
You can in first place do a “pkg_add -rv $package” en then do a “portsnap fetch ; portsnap update ; portupgrade -a”. The “old” version works fine untill portupgrade is ready with the new one.
You can in first place do a “pkg_add -rv $package” en then do a “portsnap fetch ; portsnap update ; portupgrade -a”. The “old” version works fine untill portupgrade is ready with the new one.
You forgot the:”portsnap extract”?
You do ‘portsnap extract’ only the first time to extract the whole ports tree. After that it’s update.
Edited 2006-05-10 17:35
No love for ppc
A easy way of upgrading to gnome2.14 would be:
#portsnap fetch
#portsnap extract
#portsnap update
#portupgrade -rR x11/gnome2
Not true. The correct way would be (RTFM => /usr/ports/UPDATING):
portsnap fetch
portsnap update
pkgdb -Ff
portupgrade -o net/avahi -f howl
portupgrade -o x11/gnome-screensaver -f xscreensaver-gnome
portupgrade -a
Edited 2006-05-11 09:24
portupgrade -a
This ugrades all packages (not only x11/gnome2).
If that is intentional would a “portupgrade -arR” (install upgrades of dependancies also) not be more desirable?
This release is somewhat better than 386BSD 0.1 which is the first version of “FreeBSD” that I used quite a few years ago.